Wie Icon Map Slicer filtert

Icon Map Slicer ist ein Datenschnitt, auf dem Sie zeichnen. Wählen Sie Elemente auf der Karte aus, und jedes andere Visual auf der Berichtsseite wird auf die gewählten Zeilen gefiltert. Die Karte selbst behält jedes Element: Die ausgewählten bleiben deckend, die übrigen verblassen.

Eine Karte mit Kreisen, auf der drei ausgewählte Kreise deckend und die übrigen verblasst sind, daneben eine Tabelle, die nur diese drei Filialen auflistet
Wählen Sie auf der Karte aus, und die anderen Visuals zeigen nur diese Zeilen

Was beim Auswählen geschieht

  1. Sie wählen ein oder mehrere Elemente auf der Karte aus: per Klick, mit dem Lasso, mit einem Kreis, nach Reisezeit oder mit einer Form.
  2. Icon Map Slicer sammelt die Werte des Feldes ID aus den Zeilen hinter diesen Elementen.
  3. Es wendet sie als Filter auf die Berichtsseite an, so wie ein Datenschnitt.
  4. Jedes andere Visual auf der Seite zeigt nur die Zeilen, die zu diesen IDs gehören.
Diagramm: Eine Auswahl auf der Karte filtert ein Balkendiagramm und eine Tabelle. Ein Pfeil mit der Beschriftung Filter führt von der Karte zu den anderen Visuals. Die Karte behält jedes Element und blendet die nicht ausgewählten ab
Ein Filter in eine Richtung: Die Karte filtert die Seite und behält alle eigenen Elemente

Der Filter wirkt über Ihr Datenmodell. Die anderen Visuals müssen deshalb eine Tabelle verwenden, die mit der Tabelle des Feldes ID in Beziehung steht. Ein Visual ohne Beziehung zu dieser Tabelle wird nicht gefiltert.

Es filtert, es hebt nicht hervor

Manche Power BI-Visuals führen eine Kreuzhervorhebung durch: Die anderen Visuals behalten alle ihre Daten und betonen den ausgewählten Teil. Icon Map Slicer filtert immer. Damit es ein bestimmtes Visual nicht filtert, wählen Sie die Karte aus, wählen Sie Format > Interaktionen bearbeiten und wählen Sie auf diesem Visual Keine. Die andere Möglichkeit ist Filter.

Die Karte wird nicht durch ihre eigene Auswahl gefiltert

Icon Map Slicer zeichnet weiterhin jedes Element, damit Sie Ihre Auswahl ändern können. Andere Datenschnitte, Filter und Visuals auf der Seite filtern die Karte wie gewohnt, und sie zeichnet dann nur die verbleibenden Zeilen.

Möglichkeiten der Auswahl

Werkzeug Vorgehen Einrichtung unter Seite
Klick Klicken Sie auf ein Element. Halten Sie Strg oder Umschalt gedrückt, um weitere hinzuzufügen. Immer aktiv Auswahl per Klick, Lasso und Kreis
Lasso Zeichnen Sie eine freie Form um Elemente. Auswahl > Benutzerauswahl > Lasso Auswahl per Klick, Lasso und Kreis
Kreisauswahl Ziehen Sie von einem Punkt aus einen Kreis auf. Auswahl > Benutzerauswahl > Kreisauswahl Auswahl per Klick, Lasso und Kreis
Alles innerhalb einer Form Klicken Sie auf eine Form oder auf ein Polygon einer Referenzebene, um auszuwählen, was darin liegt. Schneidende Elemente auswählen, Polygone für die Auswahl verwenden Alles innerhalb einer Form auswählen
Reisezeit Klicken Sie auf einen Ort, um auszuwählen, was in einer festgelegten Zeit oder Entfernung erreichbar ist. Auswahl > Benutzerauswahl > Isochronen-Auswahl Nach Reisezeit auswählen
Kartenausschnitt Verschieben und zoomen Sie: Die anderen Visuals zeigen nur, was im Kartenausschnitt liegt. Auswahl > Kartenposition Nach dem Kartenausschnitt filtern

Alle Auswahlwerkzeuge senden dieselbe Art von Filter, daher gelten die Einstellungen auf dieser Seite für jedes von ihnen. Das Filtern nach dem Kartenausschnitt ist ein zweiter Filter, der zusammen mit den anderen wirkt.

So sehen ausgewählte Elemente aus

Solange eine Auswahl aktiv ist, ändert die Karte die Transparenz ihrer Datenelemente. Die Einstellungen finden Sie unter Formatbereich > Auswahl > Formatierung.

Einstellung Funktion Standard
Transparenz ausgewählter Elemente Transparenz der Elemente, die Sie ausgewählt haben. 0 ist deckend, 100 ist unsichtbar. 20
Transparenz nicht ausgewählter Elemente Transparenz aller anderen Datenelemente, solange eine Auswahl aktiv ist. 80

Ist nichts ausgewählt, verwendet jede Ebene ihre eigene Transparenz.

Eine geneigte Karte mit 3D-Säulen, auf der zwei ausgewählte Säulen ihre Farbe behalten und die anderen grau geworden sind
3D-Elemente werden grau, statt zu verblassen

Gut zu wissen:

  • Die Einstellungen gelten für Kreise, Bilder, Linien, Formen, Zellen und mit einer Zeile verknüpfte Katalog-Features.
  • Datenbeschriftungen verblassen mit ihren Elementen. Es gibt keine Einstellung, mit der Beschriftungen in voller Stärke bleiben.
  • 3D-Elemente (3D-Säulen sowie extrudierte Zellen und Formen) können nicht einzeln verblassen. Nicht ausgewählte 3D-Elemente werden stattdessen grau, und die Transparenzeinstellungen gelten für sie nicht.
  • Heatmaps ändern sich nicht.
  • Wenn Sichtbarkeit der Beschriftung auf Bei Auswahl steht, zeigen nur die ausgewählten Elemente ihre Beschriftungen. Siehe Datenbeschriftungen.

Anzahl auswählbarer Elemente begrenzen

Formatbereich > Auswahl > Benutzerauswahl > Max. Auswahlen legt fest, wie viele Elemente eine Auswahl höchstens enthalten kann, von 1 bis 100.000. Der Standard ist 5.000.

Ein großer Filter kann Power BI beim Filtern der anderen Visuals ins Stocken bringen. Enthält eine Auswahl mehr Elemente als Max. Auswahlen, behält Icon Map Slicer die ersten bis zur Grenze und verwirft den Rest ohne Meldung. Erhöhen Sie die Grenze, wenn Sie größere Auswahlen brauchen und die Wartezeit in Kauf nehmen können.

Die Auswahl aufheben

Weg Vorgehen Einstellung
Auf den Hintergrund klicken Klicken Sie auf einen leeren Teil der Karte. Klick auf Hintergrund hebt Auswahl auf, standardmäßig ein. Schalten Sie die Einstellung aus, damit die Auswahl erhalten bleibt, wenn ein Leser auf den Hintergrund klickt.
Die Schaltfläche zum Aufheben Wählen Sie auf der Karte die Schaltfläche Alle Auswahlen aufheben. Schaltfläche zum Aufheben der Auswahl, standardmäßig aus. Sie befindet sich in der Formatkarte Auswahl und in der Formatkarte Benutzeroberfläche: Beide Schalter sind dieselbe Einstellung.
Erneut auf dasselbe Element klicken Wenn die Auswahl aus einem Element oder aus den Zeilen einer Zelle oder Form besteht, klicken Sie erneut darauf. Immer aktiv

Das Aufheben entfernt den Filter, sodass die anderen Visuals wieder alle ihre Zeilen zeigen. Es entfernt auch ein Reisezeitgebiet von der Karte.

Strg+Klick oder Umschalt+Klick auf ein ausgewähltes Element nimmt es aus der Auswahl heraus. Wird das letzte herausgenommen, wird der Filter aufgehoben. Ein Lasso, ein Kreis oder ein Reisezeitgebiet hebt die Auswahl nie auf, auch wenn es genau die bereits ausgewählten Elemente enthält: Nur ein Klick schaltet Elemente ab.

Gespeicherte Auswahlen und Lesezeichen

Der Filter wird wie die Auswahl eines Datenschnitts mit dem Bericht gespeichert. Wenn Sie den Bericht speichern oder ein Lesezeichen erfassen, während Elemente ausgewählt sind, öffnen sich die anderen Visuals gefiltert, und die Karte zeigt diese Elemente ausgewählt. Um neu zu beginnen, heben Sie die Auswahl auf.

Icon Map Slicer gibt an, dass es seinen Filter mit anderen Kopien von sich selbst abgleichen kann. Power BI nutzt dies für den Bereich Datenschnitte synchronisieren.

Gleichzeitig nach dem Kartenausschnitt filtern

Wenn Kartenposition eingerichtet ist, filtert das Bewegen der Karte die anderen Visuals auf den sichtbaren Bereich, und dieser Filter wird mit den ausgewählten Elementen kombiniert. Wie beide zusammenwirken, lesen Sie unter Nach dem Kartenausschnitt filtern.

Was ausgewählt werden kann

Ein Element kann ausgewählt werden, wenn es aus einer Zeile Ihrer Daten stammt und seine Ebene die Auswahl zulässt.

Ebene Einstellung
Kreise, Bilder und Symbole, Linien, Formen (aus Daten), Formen (aus Dateien), Vektorkacheln, Zellen Auswählbar: Ja oder Nein. Unterstützt die bedingte Formatierung (fx), sodass einzelne Zeilen nicht auswählbar gemacht werden können.
3D-Säulen Auswahl zulassen: Ja oder Nein. Unterstützt fx.
Mit Ihren Daten verknüpfte Icon Map-Katalogebenen Wird im Katalogfenster eingestellt.
Heatmap Kann nicht ausgewählt werden.
Formen in einer Datei, die keiner Zeile zugeordnet sind Können nicht ausgewählt werden.
Referenzebenen Nicht mit Ihren Daten verknüpft, daher nicht auswählbar. Mit einer GeoJSON-/Shape-/KML-Referenzebene lassen sich die Elemente innerhalb ihrer Polygone auswählen: siehe Alles innerhalb einer Form auswählen.

Ein an Daten gebundener ArcGIS-Layer hat ebenfalls die Einstellung Auswählbar.

Ein Element, das für mehrere Zeilen steht, wählt alle diese Zeilen aus. Ein Klick auf eine Zelle, die 40 Punkte zusammenfasst, wählt diese 40 Zeilen aus.

Steht Auswählbar auf Nein, bleiben die Elemente der Ebene aus jeder Auswahl heraus: aus Klicks, dem Lasso, der Kreisauswahl und der Reisezeit.

Drilldown

Der Feldbereich ID akzeptiert eine Hierarchie, zum Beispiel Land, Region, Bezirk. Power BI zeigt dann seine Drillschaltflächen im Visualheader. Bei eingeschaltetem Drillmodus führt ein Klick auf ein Element der Karte einen Drilldown in dieses Element aus. Ein Klick auf höchstens 20 Elemente führt einen Drilldown aus. Die Auswahl filtert die Seite trotzdem.

Ebenen, die Ihre Daten mit Formen verknüpfen, können mit der Einstellung Mehrere Ebenen anzeigen als auf jeder Stufe einen anderen Satz von Formen zeigen. Siehe Formen aus Dateien und Vektorkacheln.

Kontextmenü

Klicken Sie mit der rechten Maustaste auf ein Datenelement, um das Kontextmenü von Power BI für diese Zeile zu öffnen, mit Befehlen wie Einschließen, Ausschließen und Drillthrough. Ein Rechtsklick auf einen leeren Teil der Karte öffnet das allgemeine Menü des Visuals.

Die Karte bewegt sich nicht zur Auswahl

Standardmäßig bleibt die Ansicht unverändert, wenn Sie Elemente auswählen.

Bei einer Karte, die in 1.1.0.11 oder später hinzugefügt wurde, können Sie die Karte mit Auf ausgewählte Elemente zoomen auf die Auswahl zoomen lassen. Die Einstellung finden Sie im Grundkarten-Dialog auf der Registerkarte Ansicht und Zoom unter Auswahl und Hervorhebungen, und mit Danach wieder herauszoomen zoomt sie wieder heraus, wenn die Auswahl aufgehoben wird. Siehe Ansicht, Zoom und Projektion.

Tipps und Grenzen

  • Das Feld ID entscheidet, was gefiltert wird. Verwenden Sie die Spalte, die eine Zeile in der Tabelle eindeutig kennzeichnet, mit der Ihre anderen Visuals in Beziehung stehen, zum Beispiel einen Filialcode.
  • Elemente über Max. Auswahlen hinaus werden ohne Meldung verworfen.
  • Elemente auf der Karte lassen sich nicht mit der Tastatur auswählen.
  • Um eine Ebene von der Auswahl auszunehmen, stellen Sie ihre Einstellung Auswählbar auf Nein. Der Zeiger wird über ihren Elementen dann nicht mehr zu einer Hand.

Verwandte Themen